aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 31 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1a4b50359d..d9189b12a0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2396,6 +2396,35 @@ assemble, report on, and monitor arrays. It can also move spares between raid
arrays when needed.")
(license license:gpl2+)))
+(define-public mdadm-static
+ (package
+ (inherit mdadm)
+ (name "mdadm-static")
+ (arguments
+ (substitute-keyword-arguments (package-arguments mdadm)
+ ((#:make-flags flags)
+ `(cons "LDFLAGS = -static" ,flags))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'remove-cruft
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (precious? (lambda (file)
+ (member file '("." ".." "sbin"))))
+ (directories (scandir out (negate precious?))))
+ (with-directory-excursion out
+ (for-each delete-file-recursively directories)
+ (remove-store-references "sbin/mdadm")
+ (delete-file "sbin/mdmon")
+ #t))))))
+ ((#:modules modules %gnu-build-system-modules)
+ `((ice-9 ftw) ,@modules))
+ ((#:strip-flags _ '())
+ ''("--strip-all")) ;strip a few extra KiB
+ ((#:allowed-references _ '("out"))
+ '("out")))) ;refer only self
+ (synopsis "Statically-linked 'mdadm' command for use in an initrd")))
+
(define-public libaio
(package
(name "libaio")
@@ -2975,14 +3004,14 @@ the default @code{nsswitch} and the experimental @code{umich_ldap}.")
(define-public mcelog
(package
(name "mcelog")
- (version "143")
+ (version "144")
(source (origin
(method url-fetch)
(uri (string-append "https://git.kernel.org/cgit/utils/cpu/mce/"
"mcelog.git/snapshot/v" version ".tar.gz"))
(sha256
(base32
- "1mn5i1d6ybfxqgr6smlpxcx1wb53h0r2rp90ild7919b9yqxpk0x"))
+ "03jyhsl0s59sfqykj5p6gkb03k4w1h9ay31yxym1dnzis5sq99pa"))
(file-name (string-append name "-" version ".tar.gz"))
(modules '((guix build utils)))
(snippet