aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e4abeadaa0..88db31ee7e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1459,18 +1459,15 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(define-public strace
(package
(name "strace")
- (version "5.2")
+ (version "5.3")
(home-page "https://strace.io")
(source (origin
(method url-fetch)
(uri (string-append home-page "/files/" version
"/strace-" version ".tar.xz"))
- ;; XXX Remove the 'regenerate-tests' phase below when
- ;; "strace-ipc-tests.patch" is no longer applied.
- (patches (search-patches "strace-ipc-tests.patch"))
(sha256
(base32
- "1li49i75wrdw91hchyyd8spnzfcmxcfyfb5g9zbaza89aq4bq4ym"))))
+ "0ix06z4vnc49mv76f22kixz8dsh7daqv9mpgwcgl0mlnfjc124vc"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1479,14 +1476,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(lambda _
(substitute* "strace.c"
(("/bin/sh") (which "sh")))
- #t))
- (add-before 'configure 'regenerate-tests
- ;; XXX Remove this phase when "strace-ipc-tests.patch" is no longer
- ;; applied in the 'source' field above. This phase is needed to
- ;; regenerate many other files from tests/gen_tests.in, which is
- ;; modified by the aforementioned patch.
- (lambda _
- (invoke "tests/gen_tests.sh"))))
+ #t)))
;; Don't fail if the architecture doesn't support different personalities.
#:configure-flags '("--enable-mpers=check")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.