aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78d23b4f6a..aebbfccdbf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3153,10 +3153,12 @@ and copy/paste text in the console and in xterm.")
(lambda _ (zero? (system* "make" "static"))))
(add-after 'install 'install-bash-completion
(lambda* (#:key outputs #:allow-other-keys)
- (install-file "btrfs-completion"
- (string-append (assoc-ref outputs "out")
- "/etc/bash_completion.d"))
- #t))
+ (let* ((out (assoc-ref outputs "out"))
+ (bashcomp (string-append out "/etc/bash_completion.d")))
+ (mkdir-p bashcomp)
+ (copy-file "btrfs-completion"
+ (string-append bashcomp "/btrfs"))
+ #t)))
(add-after 'install 'install-static
(let ((staticbin (string-append (assoc-ref %outputs "static")
"/bin")))