aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm54
1 files changed, 26 insertions, 28 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index b959470d8f..3d3e6d18dc 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -34,7 +34,6 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
- #:use-module (guix build-system trivial)
#:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -254,7 +253,7 @@ spreadsheets and presentations.")
(list librevenge)) ; in Requires field of .pkg
(inputs
(list zlib))
- (home-page "http://libwpd.sourceforge.net/")
+ (home-page "https://libwpd.sourceforge.net/")
(synopsis "Library for importing WordPerfect documents")
(description "Libwpd is a C++ library designed to help process
WordPerfect documents. It is most commonly used to import such documents
@@ -345,7 +344,7 @@ way--presentation and vector drawing interfaces.")
(list libwpd)) ; in Requires field of .pkg
(inputs
(list perl zlib))
- (home-page "http://libwpg.sourceforge.net/")
+ (home-page "https://libwpg.sourceforge.net/")
(synopsis "Library and tools for the WordPerfect Graphics format")
(description "The libwpg project provides a library and tools for
working with graphics in the WPG (WordPerfect Graphics) format.")
@@ -761,7 +760,7 @@ from the old StarOffice (.sdc, .sdw, ...).")
(list librevenge))
(inputs
(list boost zlib))
- (home-page "http://libwps.sourceforge.net/")
+ (home-page "https://libwps.sourceforge.net/")
(synopsis "Import library for Microsoft Works text documents")
(description "Libwps is a library for importing files in the Microsoft
Works word processor file format.")
@@ -888,21 +887,6 @@ of decimal representation of the input floating-point number, the procedure
commonly called @code{ftoa} or @code{dtoa}.")
(license license:asl2.0)))
-(define-public dragonbox-for-libreoffice
- (package
- (inherit dragonbox)
- (name "dragonbox")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jk-jeon/dragonbox")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "11h9xhpzp61rfyh1nnca5shzi40skgpdql080k5cb6cfy672s1qz"))))))
-
(define dtoa
(origin
(method url-fetch)
@@ -915,7 +899,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "7.4.3.2")
+ (version "7.5.1.2")
(source
(origin
(method url-fetch)
@@ -924,7 +908,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
"https://download.documentfoundation.org/libreoffice/src/"
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256
- (base32 "0fyvd4ydh72lmn005h190xa563d4h376pi1fx9lfr5i25qcbpg7z"))))
+ (base32 "1dy0lvrvgkr7mbmiag26a38pivcddav8piph7jin1kw4phaxs3cj"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
@@ -935,6 +919,18 @@ commonly called @code{ftoa} or @code{dtoa}.")
(lambda _
(mkdir-p "external/tarballs")
(copy-file #$dtoa "external/tarballs/dtoa-20180411.tgz")))
+ (add-after 'unpack 'augment-LD_LIBRARY_PATH
+ ;; Without this, the nsscrypto_initialize procedure in
+ ;; nssinitializer.cxx silently fails to load libnssckbi.so, which
+ ;; causes password encryption to also silently fail (see:
+ ;; https://bugs.documentfoundation.org/show_bug.cgi?id=153714).
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "desktop/scripts/soffice.sh"
+ (("^exec .*oosplash.*" anchor)
+ (string-append "export LD_LIBRARY_PATH="
+ (search-input-directory inputs "lib/nss")
+ "${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}\n"
+ anchor)))))
(add-before 'configure 'prepare-src
(lambda* (#:key inputs #:allow-other-keys)
(substitute*
@@ -958,10 +954,10 @@ commonly called @code{ftoa} or @code{dtoa}.")
(string-append "GPGMEPP_CFLAGS=-I"
(search-input-directory inputs
"include/gpgme++")))
- (("DRAGONBOX_CFLAGS=-I/usr/include/dragonbox-1.0.0")
+ (("DRAGONBOX_CFLAGS=-I/usr/include/dragonbox-1\\.1\\.3")
(string-append "DRAGONBOX_CFLAGS=-I"
(search-input-directory inputs
- "include/dragonbox-1.0.0"))))
+ "include/dragonbox-1.1.3"))))
;; /usr/bin/xdg-open doesn't exist on Guix System.
(substitute* '("shell/source/unix/exec/shellexec.cxx"
@@ -1024,6 +1020,10 @@ commonly called @code{ftoa} or @code{dtoa}.")
#~(list
"--enable-release-build"
"--with-vendor=GNU Guix"
+ ;; Without the SAL logging system enabled, LibreOffice is utterly
+ ;; silent. Setting the environment variable 'SAL_INFO=+INFO' can be
+ ;; useful to debug problems.
+ "--enable-sal-log"
;; Avoid using all cpu cores by default
(format #f "--with-parallelism=~d" (parallel-job-count))
"--disable-fetch-external" ; disable downloads
@@ -1032,8 +1032,6 @@ commonly called @code{ftoa} or @code{dtoa}.")
(dirname
(search-input-file %build-inputs
"lib/libboost_system.so")))
- ;; Avoid a dependency on ucpp.
- "--with-idlc-cpp=cpp"
;; The fonts require an external tarball (crosextrafonts).
;; They should not be needed when system fonts are available.
"--without-fonts"
@@ -1070,7 +1068,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
clucene
cups
dbus-glib
- dragonbox-for-libreoffice
+ dragonbox
firebird
fontconfig
fontforge
@@ -1084,7 +1082,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
graphite2
gst-plugins-base
gtk+
- harfbuzz
+ harfbuzz-5
hunspell
hyphen
libabw