aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 026ce92aab..f8b1433aa3 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -183,6 +183,8 @@ spreadsheets and presentations.")
(sha256 (base32
"0436gnidx45a9vx114hhh216jrh57mqb9zyssyjfadagmyz6hgrj"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-werror")))
(native-inputs
`(("doxygen" ,doxygen)
("pkg-config" ,pkg-config)))
@@ -317,6 +319,8 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; FIXME: Man pages generation requires docbook-to-man; reenable
;; it once this is available.
"--without-man"
+ ;; XXX: A configure test fails with GCC7 when including Boost headers.
+ "--disable-werror"
;; During configure, the boost headers are found, but linking
;; fails without the following flag.
(string-append "--with-boost="
@@ -331,14 +335,14 @@ as Alfresco or Nuxeo.")
(define-public libabw
(package
(name "libabw")
- (version "0.1.2")
+ (version "0.1.3")
(source
(origin
(method url-fetch)
- (uri (string-append "https://dev-www.libreoffice.org/src/" name "/"
- name "-" version ".tar.xz"))
+ (uri (string-append "https://dev-www.libreoffice.org/src/libabw/"
+ "libabw-" version ".tar.xz"))
(sha256 (base32
- "11949iscdb99f2jplxjd39282jxcrf2fw0sqbh5dl7gqb96r8whb"))))
+ "1vbfrmnvib3cym0yyyabnd8xpx4f7wp20vnn09s6dln347fajqz7"))))
(build-system gnu-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -350,9 +354,6 @@ as Alfresco or Nuxeo.")
("libxml2" ,libxml2)))
(inputs
`(("boost" ,boost)))
- (arguments
- ;; avoid triggering configure errors by simple inclusion of boost headers
- `(#:configure-flags '("--disable-werror")))
(home-page "https://wiki.documentfoundation.org/DLP/Libraries/libabw")
(synopsis "Library for parsing the AbiWord format")
(description "Libabw is a library that parses the file format of
@@ -561,6 +562,8 @@ Java.")
(sha256 (base32
"17ai8ajffr0ixxmmcv3k5vgjlcsix38ldb4fw2arild70pbsrbb6"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-werror")))
(native-inputs
`(("doxygen" ,doxygen)
("pkg-config" ,pkg-config)))
@@ -579,14 +582,14 @@ created by PageMaker version 6.x and 7.")
(define-public libvisio
(package
(name "libvisio")
- (version "0.1.6")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/libvisio/"
"libvisio-" version ".tar.xz"))
(sha256 (base32
- "1yahpfl13qk6178irv8jn5ppxdn7isafqisyqsdw0lqxcz9h447y"))))
+ "0k7adcbbf27l7n453cca1m6s9yj6qvb5j6bsg2db09ybf3w8vbwg"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -977,7 +980,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(build-system glib-or-gtk-build-system)
(native-inputs
`(("bison" ,bison)
- ("cppunit" ,cppunit-1.14)
+ ("cppunit" ,cppunit)
("flex" ,flex)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)