aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 861a92505f..561c399eeb 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -130,8 +130,7 @@
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "configure.ac"
(("/usr/share/anthy/anthy.dic")
- (string-append (assoc-ref inputs "anthy")
- "/share/anthy/anthy.dic")))
+ (search-input-file inputs "/share/anthy/anthy.dic")))
(substitute* "configure.ac"
(("/usr/bin:\\$GTK3_LIBDIR/libgtk-3-0")
(string-append (assoc-ref inputs "gtk+:bin")
@@ -975,10 +974,11 @@ suitable for both the desktop and mobile devices.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "tegakigtk/fakekey.py"
(("libX11.so.6" so)
- (string-append (assoc-ref inputs "libx11") "/lib/" so))
+ (search-input-file inputs
+ (string-append "/lib/" so)))
(("libXtst.so.6" so)
- (string-append (assoc-ref inputs "libxtst") "/lib/" so)))
- #t))))))
+ (search-input-file inputs
+ (string-append "/lib/" so))))))))))
(inputs ; required for sending key strokes
`(("libx11" ,libx11)
("libxtst" ,libxtst)))