aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm80
1 files changed, 77 insertions, 3 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 3a15aa6554..80a3ca765e 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -47,8 +47,11 @@
#:use-module (gnu packages cpp)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages djvu)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages ebook)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -60,6 +63,7 @@
#:use-module (gnu packages kde-plasma)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages markup)
#:use-module (gnu packages maths)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
@@ -181,7 +185,8 @@ This package contains GUI widgets for baloo.")
("qtquickcontrols" ,qtquickcontrols)
("qtquickcontrols2" ,qtquickcontrols2)
("kiconthemes" ,kiconthemes)
- ("breeze" ,breeze)
+ ("breeze" ,breeze) ; make dark them available easily
+ ("breeze-icons" ,breeze-icons) ; recommended icon set
("purpose" ,purpose)
("qtwebkit" ,qtwebkit)
("qtgraphicaleffects" ,qtgraphicaleffects)
@@ -196,12 +201,14 @@ This package contains GUI widgets for baloo.")
(qtbase (assoc-ref inputs "qtbase"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
(ffmpeg (assoc-ref inputs "ffmpeg"))
- (breeze (assoc-ref inputs "breeze")))
+ (breeze (assoc-ref inputs "breeze"))
+ (breeze-icons (assoc-ref inputs "breeze-icons")))
(wrap-program (string-append out "/bin/kdenlive")
`("PATH" ":" prefix
,(list (string-append ffmpeg "/bin")))
`("XDG_DATA_DIRS" ":" prefix
- ,(list (string-append breeze "/share")))
+ ,(list (string-append breeze "/share")
+ (string-append breeze-icons "/share")))
`("QT_PLUGIN_PATH" ":" prefix
,(list (getenv "QT_PLUGIN_PATH")))
`("FREI0R_PATH" ":" =
@@ -766,6 +773,73 @@ Python, PHP, and Perl.")
(description "Runtime library for kdegames")
(license (list license:gpl2+ license:fdl1.2+))))
+(define-public okular
+ (package
+ (name "okular")
+ (version "20.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1kib8zqfd9qgqn7bz88hay2j3kcvarnlfyr3a417pi6rvaam6b4p"))))
+ (build-system qt-build-system)
+ ;; The tests fail because they can't find the proper mimetype plugins:
+ ;; "org.kde.okular.core: No plugin for mimetype '"image/jpeg"'."
+ ;; The built program seems to work okay, so we skip the tests for now.
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list "-DBUILD_TESTING=OFF")))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ebook-tools" ,ebook-tools)
+ ("breeze-icons" ,breeze-icons)
+ ("discount" ,discount)
+ ("djvulibre" ,djvulibre)
+ ("kactivities" ,kactivities)
+ ("khtml" ,khtml)
+ ("chmlib" ,chmlib)
+ ("kdegraphics-mobipocket" ,kdegraphics-mobipocket)
+ ("karchive" ,karchive)
+ ("kbookmarks" ,kbookmarks)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("qtbase" ,qtbase)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libtiff" ,libtiff)
+ ("kirigami" ,kirigami)
+ ("purpose" ,purpose)
+ ("freetype" ,freetype)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kparts" ,kparts)
+ ("kpty" ,kpty)
+ ("qtspeech" ,qtspeech)
+ ("kwallet" ,kwallet)
+ ("kwindowsystem" ,kwindowsystem)
+ ("libkexiv2" ,libkexiv2)
+ ("libspectre" ,libspectre)
+ ("libzip" ,libzip)
+ ("phonon" ,phonon)
+ ("poppler-qt5" ,poppler-qt5)
+ ("qca" ,qca)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)
+ ("threadweaver" ,threadweaver)
+ ("kcrash" ,kcrash)
+ ("kjs" ,kjs)))
+ (home-page "https://kde.org/applications/graphics/okular/")
+ (synopsis "Document viewer")
+ (description
+ "Okular is a document viewer developed for KDE. It can display files in
+a variety of formats, including PDF, PostScript, DejaVu, and EPub.")
+ (license license:gpl2+)))
+
(define-public kdegraphics-mobipocket
(package
(name "kdegraphics-mobipocket")