aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm139
1 files changed, 71 insertions, 68 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 9e1818dfaf..2993eb66f6 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -144,45 +144,20 @@ be able to view it naturally and easily.")))
(name "js-respond")
(version "1.4.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/scottjehl/Respond/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scottjehl/Respond")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ds1ya2a185jp93mdn07159c2x8zczwi960ykrawpp62bwk2n93d"))))
- (build-system trivial-build-system)
+ "00xid731rirc7sdy1gc8qal3v9g0agr2qx15hm4x97l1lcbylyn2"))))
+ (build-system minify-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils)
- (ice-9 match)
- (ice-9 popen)
- (srfi srfi-26))
- (set-path-environment-variable
- "PATH" '("bin") (map (match-lambda
- ((_ . input)
- input))
- %build-inputs))
- (let ((install-directory (string-append %output
- "/share/javascript/respond/")))
- (invoke "tar" "xvf"
- (assoc-ref %build-inputs "source")
- "--strip" "1")
- (mkdir-p install-directory)
- (let* ((file "src/respond.js")
- (installed (string-append install-directory "respond.min.js")))
- (let ((minified (open-pipe* OPEN_READ "uglify-js" file)))
- (call-with-output-file installed
- (cut dump-port minified <>)))))
- #t)))
+ `(#:javascript-files '("src/matchmedia.addListener.js"
+ "src/matchmedia.polyfill.js"
+ "src/respond.js")))
(home-page "https://github.com/scottjehl/Respond")
- (native-inputs
- `(("uglify-js" ,uglify-js)
- ("source" ,source)
- ("gzip" ,gzip)
- ("tar" ,tar)))
(synopsis "Polyfill for min/max-width CSS3 Media Queries")
(description "The goal of this script is to provide a fast and lightweight
script to enable responsive web designs in browsers that don't support CSS3
@@ -194,13 +169,14 @@ Media Queries.")
(name "js-html5shiv")
(version "3.7.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/aFarkas/html5shiv/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aFarkas/html5shiv")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0inlbpxpqzdyi24lqagzf7l24zxg0y02xcpqs2h4npjscazzw7hg"))))
+ "0y1c5nyq0brl9fjdihhax33vks4s1ij9iv113879sg3zflmgqpd0"))))
(build-system minify-build-system)
(home-page "https://github.com/aFarkas/html5shiv")
(synopsis "Enable HTML5 sectioning elements in legacy browsers")
@@ -264,13 +240,14 @@ provided by ES5. @code{JSONPath} is used to represent the links.")
(name "js-strftime")
(version "0.10.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/samsonjs/strftime/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url"https://github.com/samsonjs/strftime")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1iya43w7y26y2dp9l4d40bhjc4scb5a9mng5ng5c8hsqr82f1375"))))
+ "131nmlivazwxyba25kh9lda99749fq4xsyin6lzfalaaydviby4p"))))
(build-system minify-build-system)
(arguments
`(#:javascript-files '("strftime.js")))
@@ -287,13 +264,14 @@ well as some other extensions from Ruby.")
(name "js-highlight")
(version "9.12.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/isagalaev/highlight.js/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isagalaev/highlight.js")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1jjn9mj7fwq4zpr6is438bscf03b3q8jkj0k5c3fc6pkmjnhw939"))))
+ "12qz22qjpd6svj58pwgcwg2x2rzhihfdrxg6lgj39nfpaln6dris"))))
(build-system minify-build-system)
(arguments
`(#:javascript-files '("src/highlight.js")))
@@ -329,18 +307,41 @@ Javascript library, adding sorting, paging and filtering abilities to plain
HTML tables with minimal effort.")
(license license:expat)))
+(define-public js-requirejs
+ (package
+ (name "js-requirejs")
+ (version "2.3.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/requirejs/requirejs.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cvd5y2mb3h6yil3niqn3gjqrzixdsxcz4rvc2f0hg4kzp5y0w86"))))
+ (build-system minify-build-system)
+ (arguments `(#:javascript-files '("require.js")))
+ (home-page "https://github.com/requirejs/requirejs/")
+ (synopsis "File and module loader for JavaScript")
+ (description "RequireJS loads plain JavaScript files as well as more
+defined modules. It is optimized for in-browser use, including in a Web
+Worker, but it can be used in other JavaScript environments.")
+ (license license:expat)))
+
(define-public js-selectize
(package
(name "js-selectize")
- (version "0.12.4")
+ (version "0.12.6")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/selectize/selectize.js/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/selectize/selectize.js")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0756p49aaz34mw2dx8k1gxf210mngfrri25vkba0j7wihd2af8gn"))))
+ "15gichl8wi6yxag2ps723nxrgyan15976dzsnvw9h9py8sbyyzjn"))))
(build-system minify-build-system)
(arguments `(#:javascript-files '("src/selectize.js")))
(home-page "http://selectize.github.io/selectize.js/")
@@ -353,15 +354,16 @@ navigation; it is useful for tagging, contact lists, etc.")
(define-public js-es5-shim
(package
(name "js-es5-shim")
- (version "4.5.9")
+ (version "4.5.13")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/es-shims/es5-shim/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/es-shims/es5-shim")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0yfndyijz0ykddzprpvfjb2453gzpn528klmwycwbqc1bqd3m1hl"))))
+ "142w384fbyllq4yggv173g82lw3wix4jqcg6hkhx1ymq89vvnpmh"))))
(build-system minify-build-system)
(arguments `(#:javascript-files
'("es5-sham.js"
@@ -381,13 +383,14 @@ means that these shams cause many ES5 methods to silently fail.")
(name "js-filesaver")
(version "1.3.8")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/eligrey/FileSaver.js/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eligrey/FileSaver.js")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1rkhfqs5plaj628kzj7qgm5qahy4v7ihygifidqr6g6265mil97h"))))
+ "0gvqk0hnr8fig0n4da7vj7q6z31bcyv52916xz3rbmdj3pgpiv1d"))))
(build-system minify-build-system)
(arguments
`(#:phases