aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm79
1 files changed, 52 insertions, 27 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 5c505fde1c..47220fc75c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -7,6 +7,8 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -167,7 +169,8 @@ This package provides the classpath library.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- (list "--with-internal-libffi=no"
+ (list "--with-threading=switch" ; slower but prevents segfault
+ "--with-internal-libffi=no"
"--with-internal-libpopt=no")
#:phases
(modify-phases %standard-phases
@@ -2018,25 +2021,20 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/classpathx/servletapi/"
"servletapi-" version ".tar.gz"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07d8h051siga2f33fra72hk12sbq1bxa4jifjg0qj0vfazjjff0x"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
@@ -2665,23 +2663,31 @@ archives (jar).")
(define-public java-asm
(package
(name "java-asm")
- (version "5.2")
+ (version "6.0")
(source (origin
(method url-fetch)
(uri (string-append "http://download.forge.ow2.org/asm/"
"asm-" version ".tar.gz"))
(sha256
(base32
- "0kxvmv5275rnjl7jv0442k3wjnq03ngkb7sghs78avf45pzm4qgr"))))
+ "115l5pqblirdkmzi32dxx7gbcm4jy0s14y5wircr6h8jdr9aix00"))))
(build-system ant-build-system)
+ (propagated-inputs
+ `(("java-aqute-bndlib" ,java-aqute-bndlib)))
(arguments
`(#:build-target "compile"
;; The tests require an old version of Janino, which no longer compiles
;; with the JDK7.
#:tests? #f
- ;; We don't need these extra ant tasks, but the build system asks us to
- ;; provide a path anyway.
- #:make-flags (list (string-append "-Dobjectweb.ant.tasks.path=foo"))
+ #:make-flags
+ (list
+ ;; We don't need these extra ant tasks, but the build system asks us to
+ ;; provide a path anyway.
+ "-Dobjectweb.ant.tasks.path=dummy-path"
+ ;; The java-aqute.bndlib JAR file will be put onto the classpath and
+ ;; used during the build automatically by ant-build-system, but
+ ;; java-asm's build.xml fails unless we provide something here.
+ "-Dbiz.aQute.bnd.path=dummy-path")
#:phases
(modify-phases %standard-phases
(add-before 'install 'build-jars
@@ -3272,6 +3278,7 @@ file filters and endian classes.")
(outputs '("out" "doc"))
(arguments
`(#:test-target "test"
+ #:test-exclude (list "**/Abstract*.java" "**/Random*.java")
#:phases
(modify-phases %standard-phases
(add-after 'build 'build-javadoc ant-build-javadoc)
@@ -6952,15 +6959,16 @@ those in Perl and JavaScript.")
(define-public java-testng
(package
(name "java-testng")
- (version "6.12")
+ (version "6.14.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/cbeust/testng/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbeust/testng.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "01j2x47wkj7n5w6gpcjfbwgc88ai5654b23lb87w7nsrj63m3by6"))))
+ "0ngj88dpbqqdx9084cmiasmn9q3v5dgx45qbvxpip47nxc5x14xy"))))
(build-system ant-build-system)
(arguments
`(#:jdk ,icedtea-8; java.util.function
@@ -6968,6 +6976,20 @@ those in Perl and JavaScript.")
#:source-dir "src/main/java"
#:phases
(modify-phases %standard-phases
+ ;; FIXME: I don't know why these tests fail
+ (add-after 'unpack 'delete-failing-tests
+ (lambda _
+ (substitute* "src/test/resources/testng.xml"
+ (("<class name=\"test.configuration.github1625.TestRunnerIssue1625\"/>") "")
+ (("<class name=\"test.serviceloader.ServiceLoaderTest\" />") ""))
+ #t))
+ ;; We don't have groovy
+ (add-after 'unpack 'delete-groovy-tests
+ (lambda _
+ (delete-file-recursively "src/test/java/test/dependent/issue1648/")
+ (substitute* "src/test/resources/testng.xml"
+ (("<class name=\"test.dependent.issue1648.TestRunner\"/>") ""))
+ #t))
(add-before 'build 'copy-resources
(lambda _
(copy-recursively "src/main/resources" "build/classes")
@@ -6999,6 +7021,7 @@ those in Perl and JavaScript.")
("java-javax-inject" ,java-javax-inject)
("java-hamcrest" ,java-hamcrest-all)
("java-assertj" ,java-assertj)
+ ("java-mockito" ,java-mockito-1)
("cglib" ,java-cglib)
("asm" ,java-asm)
("aopalliance" ,java-aopalliance)))
@@ -7602,15 +7625,16 @@ protocol-independent framework to build mail and messaging applications.")
(define-public java-jeromq
(package
(name "java-jeromq")
- (version "0.4.2")
+ (version "0.4.3")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/zeromq/jeromq/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeromq/jeromq.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "17wx8dlyqmbw77xf6d6wxnhiyky6181zpf1a48jqzz9hidz0j841"))))
+ "1gxkp7lv2ahymgrqdw94ncq54bmp4m4sw5m1x9gkp7l5bxn0xsyj"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "java-jeromq.jar"
@@ -7622,6 +7646,7 @@ protocol-independent framework to build mail and messaging applications.")
;; Requires network
"**/ZBeaconTest.java"
;; Failures
+ "**/DealerSpecTest.java"
"**/CustomDecoderTest.java"
"**/CustomEncoderTest.java")))
(inputs