aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0b57d88468..87a9b791bc 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2434,7 +2434,12 @@ Wacom-style graphics tablets.")
(string-append "'" (search-input-file inputs "bin/exiftool"))))))
(add-before 'install 'check
(lambda _
- (invoke "pytest")))
+ ;; Test without PATH to make sure ‘exiftool’ is properly found.
+ (let ((path (getenv "PATH"))
+ (pytest (which "pytest")))
+ (setenv "PATH" "")
+ (invoke pytest)
+ (setenv "PATH" path))))
(add-after 'install 'install-bin
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))