aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/idris.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/idris.scm')
-rw-r--r--gnu/packages/idris.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 8f08ed3a3e..85fb6cc2d2 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -99,7 +99,7 @@
(add-before 'configure 'update-constraints
(lambda _
(substitute* "idris.cabal"
- (("(aeson|ansi-terminal|haskeline|megaparsec|optparse-applicative)\\s+[^,]+" all dep)
+ (("(aeson|ansi-terminal|bytestring|haskeline|libffi|megaparsec|network|optparse-applicative)\\s+[<>=0-9. &|]+" all dep)
dep))))
(add-before 'configure 'set-cc-command
(lambda _
@@ -122,17 +122,7 @@
(setenv "TASTY_NUM_THREADS" (number->string (parallel-job-count)))
(setenv "IDRIS_CC" ,(cc-for-target)) ;Needed for creating executables
(setenv "PATH" (string-append out "/bin:" (getenv "PATH")))
- (apply (assoc-ref %standard-phases 'check) args))))
- (add-before 'check 'restore-libidris_rts
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The Haskell build system moves this library to the
- ;; "static" output. Idris only knows how to find it in the
- ;; "out" output, so we restore it here.
- (let ((out (assoc-ref outputs "out"))
- (static (assoc-ref outputs "static"))
- (filename "/lib/idris/rts/libidris_rts.a"))
- (rename-file (string-append static filename)
- (string-append out filename))))))))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(native-search-paths
(list (search-path-specification
(variable "IDRIS_LIBRARY_PATH")