aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 258721963b..922dfbd348 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -76,17 +76,19 @@
`(("perl" ,perl)))
(arguments
`(#:configure-flags
- '("--enable-rpath"
- ,@(if (let ((s (or (%current-target-system)
- (%current-system))))
- (or (string-prefix? "arm" s)
- (string-prefix? "mips" s)))
- '("--with-data-packaging=archive")
- '()))
+ '("--enable-rpath")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir-to-source
(lambda _ (chdir "source") #t))
+ (add-after 'chdir-to-source 'update-LDFLAGS
+ (lambda _
+ ;; Do not create a "data-only" libicudata.so because it causes
+ ;; problems on some architectures (notably armhf and MIPS).
+ (substitute* "config/mh-linux"
+ (("LDFLAGSICUDT=-nodefaultlibs -nostdlib")
+ "LDFLAGSICUDT="))
+ #t))
(add-after 'install 'avoid-coreutils-reference
;; Don't keep a reference to the build tools.
(lambda* (#:key outputs #:allow-other-keys)