aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b3e7a45602..006042fd14 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13387,6 +13387,31 @@ operations. Uniplate has similar goals to the original Scrap Your Boilerplate
work, but is substantially simpler and faster.")
(license license:bsd-3)))
+(define-public ghc-unique
+ (package
+ (name "ghc-unique")
+ (version "0.4.7.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "Unique" version))
+ (sha256
+ (base32 "14f1qnmhdmbam8qis725dhwq1mk9h86fsnzhkwhsx73ny9z29s1l"))
+ (patches (search-patches "ghc-unique-support-newer-hashable.patch"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "Unique")))
+ (inputs (list ghc-extra ghc-hashable ghc-unordered-containers))
+ (native-inputs (list ghc-hspec ghc-quickcheck))
+ (arguments
+ `(#:cabal-revision ("1"
+ "10s0npnfkh7naj49afmyrvnilikp6426fbhi49f97pxrgcmy4dvw")))
+ (home-page "https://hackage.haskell.org/package/Unique")
+ (synopsis "Haskell functionality like \"uniq\" tool")
+ (description
+ "This library provides the functions to find unique and duplicate
+elements in a list.")
+ (license license:bsd-3)))
+
(define-public ghc-unix-compat
(package
(name "ghc-unix-compat")