aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm44
1 files changed, 40 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 48bee600a9..1d36e3ee2a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -212,8 +212,13 @@ without requiring the source code to be rewritten.")
(rename-file "test-suite/tests/srfi-18.test" "srfi-18.test")
;; failed to remove 't-guild-compile-7215.go.tdL7yC
(substitute* "test-suite/standalone/Makefile.in"
- (("test-guild-compile ") ""))
- #t)))
+ (("test-guild-compile ") "")))))
+ '())
+ ,@(if (system-hurd?)
+ '((add-after 'unpack 'disable-threads.tests
+ (lambda _
+ ;; Many tests hang, esp. (join-thread ..), also others.
+ (rename-file "test-suite/tests/threads.test" "threads.test"))))
'())
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
@@ -286,7 +291,12 @@ without requiring the source code to be rewritten.")
(if (target-x86-32?) ;<https://issues.guix.gnu.org/49368>
`(append '("--disable-static")
'("CFLAGS=-g -O2 -fexcess-precision=standard"))
- flags))))
+ flags))
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ #$@(if (system-hurd?)
+ #~((delete 'disable-threads.tests))
+ '())))))
(properties '((timeout . 72000) ;20 hours
(max-silent-time . 36000))) ;10 hours (needed on ARM
@@ -378,6 +388,19 @@ without requiring the source code to be rewritten.")
(search-patch "guile-hurd-posix-spawn.patch")))
(invoke "patch" "--force" "-p1" "-i" patch))))
#~())
+ #$@(if (system-hurd?)
+ #~((add-after 'unpack 'disable-popen.test-no-duplicate
+ ;; This test hangs on the Hurd.
+ (lambda _
+ (substitute* "test-suite/tests/popen.test"
+ (("\\(pass-if \"no duplicate\".*" all)
+ (string-append
+ all
+ (object->string
+ '(when (string-ci= "GNU"
+ (vector-ref (uname) 0))
+ (throw 'unresolved)))))))))
+ #~())
#$@(if (target-ppc32?)
#~((add-after 'unpack 'adjust-bootstrap-flags
(lambda _
@@ -829,7 +852,20 @@ type system, elevating types to first-class status.")
(lambda _
(substitute* "Makefile.am"
((".*tests/blob\\.scm.*") ""))))))
- '())))
+ '())
+ ,@(if (system-hurd?)
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-tests/hurd
+ (lambda _
+ (substitute* "tests/proxy.scm"
+ (("\\(test-begin.*" all)
+ (string-append
+ all
+ "(when (string-ci= \"GNU\" (vector-ref (uname) 0))\n"
+ " (test-skip 1))\n")))))))
+ '())))
(native-inputs
(list pkg-config autoconf automake texinfo guile-3.0 guile-bytestructures))
(inputs