aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f575194c73..b9ef660a80 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2146,7 +2147,7 @@ so that they can be used normally in signals and properties.")
"0ry9jfvfgdwzalxcvwsgr7plhk3agx7p40l0fqdf3vrf7ds47i29"))))
(build-system perl-build-system)
(native-inputs
- (list perl-extutils-depends perl-extutils-pkgconfig))
+ (list perl-extutils-depends perl-extutils-pkgconfig pkg-config))
(inputs
(list gtk+-2))
(propagated-inputs
@@ -2461,7 +2462,7 @@ glass artworks done by Venicians glass blowers.")
(list gobject-introspection gtk+ pango))
(propagated-inputs
(list enchant)) ; gtkspell3-3.0.pc refers to it
- (home-page "http://gtkspell.sourceforge.net")
+ (home-page "https://gtkspell.sourceforge.net")
(synopsis "Spell-checking addon for GTK's TextView widget")
(description
"GtkSpell provides word-processor-style highlighting and replacement of
@@ -2516,7 +2517,7 @@ Parcellite and adds bugfixes and features.")
"-Dinstalled_tests=false"
,@(if (%current-target-system)
;; Introspection requires running binaries for 'host' on 'build'.
- '("-Dintrospection=false")
+ '("-Dintrospection=disabled")
'()))))
(native-inputs
`(("git" ,git-minimal/pinned)