aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 852d095300..d2481cf25b 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -66,11 +66,7 @@
;; TODO: "make doc" requires Docbook & co.
(arguments
`(#:configure-flags
- '("--with-zlib=system"
- ;; XXX Use -fPIC to work around build problems with Qt, GCC 5, and
- ;; recent binutils:
- ;; https://codereview.qt-project.org/#/c/111787/
- "CXXFLAGS=-std=gnu++11 -fPIC")
+ '("--with-zlib=system")
;; On i686, 'raymarine.test' fails because of a rounding error:
;; <http://hydra.gnu.org/build/133040>. As a workaround, disable tests
;; on these platforms.
@@ -147,7 +143,7 @@ between two other data points.")
(define-public gama
(package
(name "gama")
- (version "2.06")
+ (version "2.07")
(source
(origin
(method url-fetch)
@@ -155,7 +151,7 @@ between two other data points.")
version ".tar.gz"))
(sha256
(base32
- "06xp3kj099b6m2fsmgcbzgj7xk4j0drsps52m4fr8vc6fglsh44p"))))
+ "0nmc6mkd55nryfffq5k9c09dhkbq6bfs06af8ammhbh5jzdn3s36"))))
(build-system gnu-build-system)
(arguments '(#:parallel-tests? #f)) ; race condition
(native-inputs
@@ -175,7 +171,7 @@ coordinates as well as partial support for adjustments in global coordinate syst
(define-public gpxsee
(package
(name "gpxsee")
- (version "7.8")
+ (version "7.12")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -184,7 +180,7 @@ coordinates as well as partial support for adjustments in global coordinate syst
(file-name (git-file-name name version))
(sha256
(base32
- "1ymqz4wrl9ghkyyqi2vrnlyvz3fc84s3p8a1dkiqlvyvj360ck9j"))))
+ "0c3axs3mm6xzabwbvy9vgq1sryjpi4h91nwzy9iyv9zjxz7phgzc"))))
(build-system gnu-build-system)
(arguments
'(#:phases