aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gprolog.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gprolog.scm')
-rw-r--r--gnu/packages/gprolog.scm68
1 files changed, 0 insertions, 68 deletions
diff --git a/gnu/packages/gprolog.scm b/gnu/packages/gprolog.scm
deleted file mode 100644
index 166bf33294..0000000000
--- a/gnu/packages/gprolog.scm
+++ /dev/null
@@ -1,68 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages gprolog)
- #:use-module (guix download)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix build-system gnu)
- #:use-module (srfi srfi-1))
-
-(define-public gprolog
- (package
- (name "gprolog")
- (version "1.4.5")
- (source
- (origin
- (method url-fetch)
- ;; Recent versions are not hosted on the GNU mirrors.
- (uri (list (string-append "http://gprolog.org/gprolog-" version
- ".tar.gz")
- (string-append "mirror://gnu/gprolog/gprolog-" version
- ".tar.gz")))
- (sha256
- (base32
- "0z4cc42n3k6i35b8mr816iwsvrpxshw6d7dgz6s2h1hy0l7g1p5z"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append
- "--with-install-dir=" %output "/share/gprolog"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'change-dir-n-fix-shells
- (lambda _
- (chdir "src")
- (substitute* "configure"
- (("-/bin/sh") (string-append "-" (which "sh")))
- (("= /bin/sh") (string-append "= " (which "sh"))))
- #t)))))
- (home-page "https://www.gnu.org/software/gprolog/")
- (synopsis "Prolog compiler")
- (description
- "GNU Prolog is a standards-compliant Prolog compiler with constraint
-solving over finite domains. It accepts Prolog+ constraint programs and
-produces a compiled, native binary which can function in a stand-alone
-manner. It also features an interactive interpreter.")
- (license (list gpl2+ lgpl3+))
-
- ;; See 'configure' for the list of supported architectures.
- (supported-systems (fold delete
- %supported-systems
- '("armhf-linux" "mips64el-linux")))))