aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2bf4da8eba..518bda7299 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7361,7 +7361,17 @@ formatting information, rather than the current locale name.")
(file-name (git-file-name name version))
(sha256
(base32
- "006y6mlxglr2xzmdqxl5bwh899whfx1prcgjai7qhhs5ys5dspy5"))))
+ "006y6mlxglr2xzmdqxl5bwh899whfx1prcgjai7qhhs5ys5dspy5"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Submodules with their own go.mod files and packed as
+ ;; separated packages:
+ ;;
+ ;; - github.com/prometheus/common/assets
+ ;; - github.com/prometheus/common/sigv4
+ (for-each delete-file-recursively
+ (list "assets" "sigv4"))))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/prometheus/common"