aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm115
1 files changed, 90 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 32a897bfbb..c41ed0bb1a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1191,6 +1191,46 @@ Features include:
optimized for performance yet simple to use.")
(license license:expat))))
+(define-public go-github-com-tomnomnom-gron
+ (package
+ (name "gron")
+ (version "0.6.0")
+ (home-page "https://github.com/tomnomnom/gron")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05f3w4zr15wd7xk75l12y5kip4gnv719a2x9w2hy23q3pnss9wk0"))))
+ (build-system go-build-system)
+ (arguments
+ (let ((import-path "github.com/tomnomnom/gron"))
+ `(#:import-path ,import-path
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'check 'remove-non-source
+ (lambda _
+ (for-each (lambda (dir)
+ (delete-file-recursively
+ (string-append "src/" ,import-path dir)))
+ '("/docs" "/script" "/testdata"))
+ #t))))))
+ (inputs
+ `(("github.com/fatih/color" ,go-github-com-fatih-color)
+ ("github.com/mattn/go-colorable" ,go-github-com-mattn-go-colorable)
+ ("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
+ ("github.com/nwidger/jsoncolor" ,go-github-com-nwidger-jsoncolor)
+ ("github.com/pkg/errors" ,go-github-com-pkg-errors)))
+ (synopsis "Transform JSON to make it easier to grep")
+ (description
+ "This package transforms JSON into discrete assignments to make it easier
+to use line-based tools such as grep to search for what you want and see the
+absolute \"path\" to it.")
+ (license license:expat)))
+
(define-public go-github-com-tv42-httpunix
(let ((commit "2ba4b9c3382c77e7b9ea89d00746e6111d142a22")
(revision "0"))
@@ -2120,32 +2160,30 @@ terminal.")
(license license:expat)))
(define-public go-github-com-mattn-go-colorable
- (let ((commit "efa589957cd060542a26d2dd7832fd6a6c6c3ade")
- (revision "0"))
- (package
- (name "go-github-com-mattn-go-colorable")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-colorable")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0kshi4hvm0ayrsxqxy0599iv81kryhd2fn9lwjyczpj593cq069r"))))
- (build-system go-build-system)
- (native-inputs
- `(("go-github-com-mattn-go-isatty"
- ,go-github-com-mattn-go-isatty)))
- (arguments
- '(#:import-path "github.com/mattn/go-colorable"))
- (home-page "https://github.com/mattn/go-colorable")
- (synopsis "Handle ANSI color escapes on Windows")
- (description "This package provides @code{colorable}, a module that
+ (package
+ (name "go-github-com-mattn-go-colorable")
+ (version "0.1.8")
+ (home-page "https://github.com/mattn/go-colorable")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q34zqwbnls72md8q8mhj368s7p3i4xspvs3rk8fs76s0pn7dr2l"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-mattn-go-isatty"
+ ,go-github-com-mattn-go-isatty)))
+ (arguments
+ '(#:import-path "github.com/mattn/go-colorable"))
+ (synopsis "Handle ANSI color escapes on Windows")
+ (description "This package provides @code{colorable}, a module that
makes it possible to handle ANSI color escapes on Windows.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-mattn-go-pointer
(let ((commit "a0a44394634f41e4992b173b24f14fecd3318a67")
@@ -5342,6 +5380,33 @@ style your output, without you having to deal with all kinds of weird ANSI
escape sequences and color conversions.")
(license license:expat)))
+(define-public go-github-com-nwidger-jsoncolor
+ (package
+ (name "go-github-com-nwidger-jsoncolor")
+ (version "0.3.0")
+ (home-page "https://github.com/nwidger/jsoncolor")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13rd146pnj7qm70r1333gyd1f61x40nafxlpvdxlci9h7mx8c5p8"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/nwidger/jsoncolor"))
+ (native-inputs
+ `(("go-github-com-fatih-color" ,go-github-com-fatih-color)))
+ (synopsis "Colorized JSON marshalling and encoding")
+ (description
+ "@code{jsoncolor} is a drop-in replacement for @code{encoding/json}'s
+@code{Marshal} and @code{MarshalIndent} functions and @code{Encoder} type
+which produce colorized output using github.com/fatih/color.")
+ (license license:expat)))
+
(define-public go-github-com-olekukonko-tablewriter
(package
(name "go-github-com-olekukonko-tablewriter")