aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0bdd3803fd..1d8e80c8fe 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1673,3 +1673,32 @@ incoming requests with their respective handler.")
"Replace uses of the @code{time} package with the
@code{clockwork.Clock} interface instead.")
(license license:asl2.0))))
+
+(define-public go-github-com-spf13-pflag
+ (let ((commit "4f9190456aed1c2113ca51ea9b89219747458dc1")
+ (revision "0"))
+ (package
+ (name "go-github-com-spf13-pflag")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spf13/pflag.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12vrlcsbwjqlfc49rwky45mbcj74c0kb6z54354pzas6fwzyi1kc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/spf13/pflag"))
+ (home-page "https://github.com/spf13/pflag")
+ (synopsis "Replacement for Go's @code{flag} package")
+ (description
+ "Pflag is library to replace Go's @code{flag} package. It implements
+POSIX/GNU-style command-line options with double hyphens. It is is compatible
+with the
+@uref{https://www.gnu.org/software/libc/manual/html_node/Argument-Syntax.html,
+GNU extensions} to the POSIX recommendations for command-line options.")
+ (license license:bsd-3))))