aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1e2a7510d2..fa6c8ff605 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7400,6 +7400,40 @@ remains is just the @code{runewidth.RuneWidth()} function.")
terminals.")
(license license:expat)))
+(define-public go-zgo-at-zstd
+ (package
+ (name "go-zgo-at-zstd")
+ (version "0.0.0-20240922235538-9a93b98b4725")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arp242/zstd")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06nqiv1pkqnnqa3v6rlf0qfxgfd63vi4vv36acq54dxswxhcasaz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "zgo.at/zstd"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v"
+ "-skip" "TestExists"
+ "./..."))))))))
+ (home-page "https://github.com/arp242/zstd")
+ (synopsis "Extensions to Go's standard library")
+ (description
+ "Package @samp{zstd} is a collection of extensions to Go's standard
+library.")
+ (license license:expat)))
+
;;;
;;; Executables:
;;;