aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 2ddad9afe2..dca461f5d4 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -72,7 +72,7 @@
(("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE")))))
(build-system gnu-build-system)
(native-inputs
- `(("perl", perl)
+ `(("perl" ,perl)
("python" ,python-2)))
(arguments
`(#:phases
@@ -154,7 +154,7 @@ in C/C++.")
"01ria9wk6329hxqsy75p9dkxiqkq4nkz0jjzll7hslih3jbi8dil"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl", perl)))
+ `(("perl" ,perl)))
(arguments
`(#:tests? #f ; no check target
#:configure-flags (list "--enable-64bit"
@@ -289,7 +289,8 @@ standards.")
"0bd4k5cwr8ynscaxffvj2x3kgky3dmjq0qhpcb931l98bh0103lx"))
(patches (map search-patch
'("icecat-avoid-bundled-includes.patch"
- "icecat-re-enable-DHE-cipher-suites.patch")))
+ "icecat-re-enable-DHE-cipher-suites.patch"
+ "icecat-update-graphite2.patch")))
(modules '((guix build utils)))
(snippet
'(begin
@@ -318,6 +319,8 @@ standards.")
;; TODO: Use system harfbuzz. Waiting for:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=847568>
;;
+ ;; TODO: Use system graphite2.
+ ;;
"modules/freetype2"
"modules/zlib"
"modules/libbz2"