aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4137a12c2f..eaf47033a3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6474,7 +6474,7 @@ USB transfers with your high-level application or system daemon.")
(define-public simple-scan
(package
(name "simple-scan")
- (version "3.38.1")
+ (version "3.38.2")
(source
(origin
(method url-fetch)
@@ -6482,7 +6482,7 @@ USB transfers with your high-level application or system daemon.")
(version-major+minor version) "/"
"simple-scan-" version ".tar.xz"))
(sha256
- (base32 "0grscz96bwj79ka4qvxh8h75avdx6824k8k38ylmaj6xbl6gi0hy"))))
+ (base32 "02sdkhxgr6i7iy481h4xavgaqd0a5dlsipzwrm4qd242jrr813d8"))))
(build-system meson-build-system)
;; TODO: Fix icons in home screen, About dialogue, and scan menu.
(arguments
@@ -6802,6 +6802,7 @@ freedesktop.org help system specification.")
(inputs
`(("yelp-xsl" ,yelp-xsl)))
(propagated-inputs
+ ;; Needed by `yelp-build', `yelp-check' or 'yelp.m4'.
`(("itstool" ,itstool)
("xmllint" ,libxml2)
("xsltproc" ,libxslt)))
@@ -11892,6 +11893,9 @@ libraries. Applications do not need to be recompiled--or even restarted.")
"-Dplugin_clang=false"
"-Dplugin_flatpak=false"
"-Dplugin_glade=false"
+ ;; XXX: This one has been shown not to work in
+ ;; <https://issues.guix.gnu.org/45272>
+ "-Dplugin_jedi=false"
;; ... except this one.
"-Dplugin_update_manager=false")
#:phases
@@ -11952,7 +11956,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(define-public komikku
(package
(name "komikku")
- (version "0.23.0")
+ (version "0.24.0")
(source
(origin
(method git-fetch)
@@ -11962,7 +11966,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "1xh3qmf2pk80qxj528lajjcwg7mps72s1zz8cj388av58p8l3hyw"))))
+ "010p32zrim245y0l784yp0rasqcqlyr3lrxwl3r1876x83qhs6q3"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11994,7 +11998,6 @@ integrated profiler via Sysprof, debugging support, and more.")
("libnotify" ,libnotify)
("libsecret" ,libsecret)
("python-beautifulsoup4" ,python-beautifulsoup4)
- ("python-cloudscraper" ,python-cloudscraper)
("python-dateparser" ,python-dateparser)
("python-keyring" ,python-keyring)
("python-lxml" ,python-lxml)
@@ -12003,6 +12006,7 @@ integrated profiler via Sysprof, debugging support, and more.")
("python-pure-protobuf" ,python-pure-protobuf)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
+ ("python-requests" ,python-requests)
("python-unidecode" ,python-unidecode)))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)