aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 026b5fd59c..bf63c37c2b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1321,9 +1321,13 @@ functionality was designed to be as reusable and portable as possible.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- ;; The programmer kindly gives us a hook to turn off deprecation
- ;; warnings ...
- '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+ '(;; We don't need static libraries, plus they don't build reproducibly
+ ;; (non-deterministic ordering of .o files in the archive.)
+ "--disable-static"
+
+ ;; The programmer kindly gives us a hook to turn off deprecation
+ ;; warnings ...
+ "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
;; ... which they then completly ignore !!
#:phases
(modify-phases %standard-phases