aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dce9639cb8..dffcd697d7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8643,7 +8643,7 @@ compiled.")
(define-public gfbgraph
(package
(name "gfbgraph")
- (version "0.2.3")
+ (version "0.2.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8652,17 +8652,23 @@ compiled.")
"gfbgraph-" version ".tar.xz"))
(sha256
(base32
- "1dp0v8ia35fxs9yhnqpxj3ir5lh018jlbiwifjfn8ayy7h47j4fs"))))
+ "0yck7dwvjk16a52nafjpi0a39rxwmg0w833brj45acz76lgkjrb0"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:tests? #f ; Tests appear to require the network.
- ;; FIXME --enable-gtk-doc fails even with gtk-doc as a native-input.
- #:configure-flags '("--disable-gtk-doc"
- "--disable-static"
+ `(#:tests? #f ; tests appear to require the network
+ #:configure-flags '("--disable-static"
+ "--enable-gtk-doc"
"--enable-introspection")))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gobject-introspection" ,gobject-introspection)))
+ `(("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+
+ ;; The 0.2.4 ‘release’ tarball isn't bootstrapped.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("which" ,which)))
(inputs
`(("json-glib" ,json-glib)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")