aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1d44ef8ee1..e378474147 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -235,7 +235,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.1.9")
+ (version "20.2.4")
(source
(origin
(method url-fetch)
@@ -247,9 +247,9 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "10kk8a8k7f4ip8yaiqdyrx162nbw8pw4h3b4hs4ha8mpd43wlldj"))
+ "14m09bk7akj0k02lg8fhvvzbdsashlbdsgl2cw7wbqfj2mhdqwh5"))
(patches
- (search-patches "mesa-skip-disk-cache-test.patch"))))
+ (search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
(propagated-inputs
`(;; The following are in the Requires.private field of gl.pc.
@@ -272,7 +272,7 @@ also known as DXTn or DXTC) for Mesa.")
,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
;; Note: update the 'clang' input of mesa-opencl when bumping this.
- `(("llvm" ,llvm-10)))
+ `(("llvm" ,llvm-11)))
(_
`()))
("wayland" ,wayland)
@@ -452,7 +452,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
`(("libclc" ,libclc)
,@(package-inputs mesa)))
(native-inputs
- `(("clang" ,clang-10)
+ `(("clang" ,clang-11)
,@(package-native-inputs mesa)))))
(define-public mesa-opencl-icd