aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index f9c3ee94bf..3b74a96966 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -47,12 +47,13 @@
(define-public lcms
(package
(name "lcms")
- (replacement lcms/fixed)
(version "2.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/lcms/lcms/" version
"/lcms2-" version ".tar.gz"))
+
+ (patches (search-patches "lcms-CVE-2018-16435.patch"))
(sha256 (base32
"083xisy6z01zhm7p7rgk4bx9d6zlr8l20qkfv1g29ylnhgwzvij8"))))
(build-system gnu-build-system)
@@ -68,14 +69,6 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(home-page "http://www.littlecms.com/")
(properties '((cpe-name . "little_cms_color_engine")))))
-(define lcms/fixed
- (package
- (inherit lcms)
- (source
- (origin
- (inherit (package-source lcms))
- (patches (search-patches "lcms-CVE-2018-16435.patch"))))))
-
(define-public libpaper
(package
(name "libpaper")
@@ -144,7 +137,7 @@ printing, and psresize, for adjusting page sizes.")
(define-public ghostscript
(package
(name "ghostscript")
- (version "9.26")
+ (version "9.27")
;; The problems addressed by GHOSTSCRIPT/FIXED are not security-related,
;; but they have a significant impact on usability, hence this graft.
@@ -160,7 +153,7 @@ printing, and psresize, for adjusting page sizes.")
"/ghostscript-" version ".tar.xz"))
(sha256
(base32
- "1645f47all5w27bfhiq15vycdm954lmr6agqkrp68ksq6xglgvch"))
+ "06dnj0mxyaryfbwlsjwaqf847w91w2h8f108kxxcc41nrnx1y3zw"))
(patches (search-patches "ghostscript-no-header-creationdate.patch"
"ghostscript-no-header-id.patch"
"ghostscript-no-header-uuid.patch"))
@@ -178,6 +171,13 @@ printing, and psresize, for adjusting page sizes.")
(outputs '("out" "doc")) ;19 MiB of HTML/PS doc + examples
(arguments
`(#:disallowed-references ("doc")
+ ;; XXX: Starting with version 9.27, building the tests in parallel
+ ;; occasionally fails like this:
+ ;; In file included from ./base/memory_.h:23:0,
+ ;; from ./obj/gsmd5.h:1,
+ ;; from ./obj/gsmd5.c:56:
+ ;; ./base/std.h:25:10: fatal error: arch.h: No such file or directory
+ #:parallel-tests? #f
#:configure-flags
(list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib")