aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8e8e6dbe3b..32cdc2b53a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -252,12 +253,14 @@ and driving.")
(inputs
`(("libjpeg-turbo" ,libjpeg-turbo)
("libtiff" ,libtiff)
- ("proj" ,proj)
("zlib" ,zlib)))
+ (propagated-inputs
+ `(;; libgeotiff headers include proj headers, so ensure those are available.
+ ("proj" ,proj)))
(arguments
`(#:configure-flags
- (list (string-append "--with-zlib")
- (string-append "--with-jpeg")
+ (list "--disable-static"
+ "--with-zlib" "--with-jpeg"
(string-append "--with-libtiff=" (assoc-ref %build-inputs "libtiff")))))
(synopsis "Library for handling GeoTIFF (geographic enabled TIFF)")
(description "libgeotiff is a library on top of libtiff for reading and