aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm43
1 files changed, 24 insertions, 19 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 024a9dd883..a05b86219e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -216,7 +216,7 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
(define-public geos
(package
(name "geos")
- (version "3.8.1")
+ (version "3.10.2")
(source (origin
(method url-fetch)
(uri (string-append "http://download.osgeo.org/geos/geos-"
@@ -224,8 +224,8 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
".tar.bz2"))
(sha256
(base32
- "1xqpmr10xi0n9sj47fbwc89qb0yr9imh4ybk0jsxpffy111syn22"))))
- (build-system gnu-build-system)
+ "05apyh6dvv15fax4xvxa0kr622h4y08w9p3274mlqsrqmjcwbfsh"))))
+ (build-system cmake-build-system)
(arguments `(#:phases
(modify-phases %standard-phases
(add-after
@@ -233,11 +233,10 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
(lambda _
(substitute* '("tests/xmltester/testrunner.sh"
"tests/geostest/testrunner.sh")
- (("/bin/sh") (which "sh")))
- #t)))))
+ (("/bin/sh") (which "sh"))))))))
(inputs
(list glib))
- (home-page "https://geos.osgeo.org/")
+ (home-page "https://libgeos.org/")
(synopsis "Geometry Engine for Geographic Information Systems")
(description
"GEOS provides a spatial object model and fundamental geometric
@@ -342,18 +341,14 @@ and driving.")
(define-public libgeotiff
(package
(name "libgeotiff")
- (version "1.5.1")
+ (version "1.7.1")
(source
(origin
(method url-fetch)
(uri (string-append "http://download.osgeo.org/geotiff/libgeotiff/libgeotiff-"
version ".tar.gz"))
- (patches (search-patches
- ;; See libgeotiff 1.5.1 issue
- ;; https://github.com/OSGeo/libgeotiff/issues/22
- "libgeotiff-adapt-test-script-for-proj-6.2.patch"))
(sha256
- (base32 "0b31mlzcv5b1y7jdvb7p0pa3xradrg3x5g32ym911lbhq4rrgsgr"))
+ (base32 "1mjmgv48x51ppax5dnb6lq7z600czxll53bx6jbzqwd4m93i7aq5"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2213,7 +2208,7 @@ orienteering sport.")
(license license:gpl3+)))
(define-public grass
- (let* ((version "7.8.6")
+ (let* ((version "7.8.7")
(majorminor (string-join (list-head (string-split version #\.) 2) ""))
(grassxx (string-append "grass" majorminor)))
(package
@@ -2225,7 +2220,7 @@ orienteering sport.")
(uri (string-append "https://grass.osgeo.org/" grassxx
"/source/grass-" version ".tar.gz"))
(sha256
- (base32 "1glk74ly3j0x8ymn4jp73s6y8qv7p3g5nv4gvb6l9qqplyq1fpnq"))))
+ (base32 "0sbz0ba9p963phvd0gmvfqq1fg4ixpipzcjbf20ys86qavjppzsg"))))
(build-system gnu-build-system)
(inputs
`(("bzip2" ,bzip2)
@@ -2336,7 +2331,7 @@ visualization.")
(define-public saga
(package
(name "saga")
- (version "7.9.0")
+ (version "8.2.1")
(source
(origin
(method url-fetch)
@@ -2344,8 +2339,8 @@ visualization.")
(version-major version) "/SAGA%20-%20" version
"/saga-" version ".tar.gz"))
(sha256
- (base32 "1n051yxxkylly0k9rlkx2ih3j2lf9d4csg00sm7161r7nhjvggd1"))))
- (build-system gnu-build-system)
+ (base32 "008izjs6gvj09abxf16ssl1xy0ay3ljq4jswbggp6wiiq459minv"))))
+ (build-system cmake-build-system)
(native-inputs
(list pkg-config swig))
(inputs
@@ -2365,7 +2360,12 @@ visualization.")
vigra
wxwidgets))
(arguments
- '(#:configure-flags '("--enable-python")))
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'cd-to-source-dir
+ (lambda _
+ (chdir "saga-gis"))))))
(synopsis "System for Automated Geoscientific Analyses")
(description
"SAGA (System for Automated Geoscientific Analyses) is a Geographic
@@ -2486,12 +2486,14 @@ growing set of geoscientific methods.")
"PyQgsLayoutHtml"
"PyQgsLayoutLegend"
"PyQgsLayoutMapGrid"
+ "PyQgsMapClippingUtils"
"PyQgsMapLayer"
"PyQgsMetadataBase"
"PyQgsOGRProvider"
"PyQgsOGRProviderGpkg"
"PyQgsOapifProvider"
"PyQgsPalLabelingLayout"
+ "PyQgsProcessingInPlace"
"PyQgsProject"
"PyQgsProviderConnectionGpkg"
"PyQgsProviderConnectionPostgres"
@@ -2528,6 +2530,7 @@ growing set of geoscientific methods.")
"qgis_layoutlabeltest"
"qgis_layoutmanualtabletest"
"qgis_layoutmapgridtest"
+ "qgis_layoutmapoverviewtest"
"qgis_layoutmaptest"
"qgis_layoutmultiframetest"
"qgis_layoutpicturetest"
@@ -2535,6 +2538,7 @@ growing set of geoscientific methods.")
"qgis_layouttest"
"qgis_mapdevicepixelratiotest"
"qgis_maprendererjobtest"
+ "qgis_meshcontourstest"
"qgis_ogrproviderguitest"
"qgis_painteffecttest"
"qgis_pallabelingtest"
@@ -2548,7 +2552,8 @@ growing set of geoscientific methods.")
"qgis_svgmarkertest"
"qgis_taskmanagertest"
"qgis_wcsprovidertest"
- "qgis_ziplayertest")
+ "qgis_ziplayertest"
+ "TestQgsRandomMarkerSymbolLayer")
"|")))))
(add-after 'install 'wrap-python
(assoc-ref python:%standard-phases 'wrap))