aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9ae6f77b37..fade5bb64b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -719,10 +719,9 @@ It also includes runtime support libraries for these languages.")
(if (target-hurd?)
`(modify-phases ,phases
(add-after 'unpack 'patch-hurd-libpthread
- (lambda (#:key inputs)
+ (lambda _
(invoke "patch" "--force" "-p1" "-i"
- (assoc-ref inputs "hurd-patch")
- patch))))
+ (assoc-ref %build-inputs "hurd-patch")))))
phases))))
(properties
`((compiler-cpu-architectures