aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5896fa4333..d884df588a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7530,15 +7530,16 @@ original.")
(strip-store-file-name
#$shlomif-cmake-modules)))))
(replace 'check
- (lambda _
- (with-directory-excursion "../source"
- (setenv "FCS_TEST_BUILD" "1")
- (setenv "RINUTILS_TEST_BUILD" "1")
- ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
- ;; which requires tidy-all.
- ;; (setenv "RINUTILS_TEST_TIDY" "1")
- (invoke "perl"
- "CI-testing/continuous-integration-testing.pl")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "../source"
+ (setenv "FCS_TEST_BUILD" "1")
+ (setenv "RINUTILS_TEST_BUILD" "1")
+ ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
+ ;; which requires tidy-all.
+ ;; (setenv "RINUTILS_TEST_TIDY" "1")
+ (invoke "perl"
+ "CI-testing/continuous-integration-testing.pl"))))))))
(native-inputs
(list perl
;; The following are needed only for tests.