aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 19 insertions, 13 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b025dfe232..7f84e447bb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2016 David Thompson <dthompson2@worcester.edu>
-;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
;;; Copyright © 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
@@ -3259,7 +3259,7 @@ safety of the Chromium vessel.")
(define-public tuxpaint
(package
(name "tuxpaint")
- (version "0.9.22") ;keep VER_DATE below in sync
+ (version "0.9.23") ;keep VER_DATE below in sync
(source
(origin
(method url-fetch)
@@ -3267,7 +3267,7 @@ safety of the Chromium vessel.")
version "/tuxpaint-" version ".tar.gz"))
(sha256
(base32
- "1qrbrdck9yxpcg3si6jb9i11w8lw9h4hqad0pfaxgyiniqpr7gca"))
+ "09k9pxi88r3dx6dyjwf9h85d4qpva4i29qz63dc558hg9v21k69l"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3295,16 +3295,22 @@ safety of the Chromium vessel.")
("sdl" ,(sdl-union (list sdl sdl-mixer sdl-ttf sdl-image)))))
;; TODO: Use system fonts rather than those in data/fonts
(arguments
- `(#:make-flags `("VER_DATE=2014-08-23"
+ `(#:make-flags `("VER_DATE=2018-09-02"
"GPERF=gperf" "CC=gcc"
"SDL_PCNAME=sdl SDL_image SDL_mixer SDL_ttf"
,(string-append "PREFIX=" %output)
- "GNOME_PREFIX=$(PREFIX)"
+ "KDE_PREFIX=$(PREFIX)/share/applications"
+ "KDE_ICON_PREFIX=$(PREFIX)/share/icons/"
"COMPLETIONDIR=$(PREFIX)/etc/bash_completion.d")
#:parallel-build? #f ;fails on some systems
#:tests? #f ;No tests
#:phases (modify-phases %standard-phases
(delete 'configure) ;no configure phase
+ (add-before 'install 'no-sys-cache
+ (lambda _ ;do not rebuild system conf cache
+ (substitute* "Makefile"
+ (("kbuildsycoca4") ""))
+ #t))
(add-after 'install 'fix-import
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -3336,7 +3342,7 @@ your child be creative.")
(define-public tuxpaint-stamps
(package
(name "tuxpaint-stamps")
- (version "2014.08.23")
+ (version "2018.09.01")
(source
(origin
(method url-fetch)
@@ -3345,7 +3351,7 @@ your child be creative.")
"/tuxpaint-stamps-" version ".tar.gz"))
(sha256
(base32
- "0rhlwrjz44wp269v3rid4p8pi0i615pzifm1ym6va64gn1bms06q"))))
+ "1skr23k27yj3vgwfazpzxp90lb2a278gxrkr3bxw7az6zpkmb3yp"))))
(build-system trivial-build-system)
(native-inputs
`(("tar" ,tar)
@@ -3374,7 +3380,7 @@ with the \"Stamp\" tool within Tux Paint.")
(define-public tuxpaint-config
(package
(name "tuxpaint-config")
- (version "0.0.13") ;keep VER_DATE below in sync
+ (version "0.0.14") ;keep VER_DATE below in sync
(source
(origin
(method url-fetch)
@@ -3382,7 +3388,7 @@ with the \"Stamp\" tool within Tux Paint.")
version "/tuxpaint-config-" version ".tar.gz"))
(sha256
(base32
- "1z12s46mvy87qs3vgq9m0ki9pp21zqc52mmgphahpihw3s7haf6v"))))
+ "0zkgxk436nqcp43zghkfmh397c7dvh5bwn2as7gwvv208bzyij6g"))))
(build-system gnu-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)))
@@ -3394,7 +3400,7 @@ with the \"Stamp\" tool within Tux Paint.")
("libxft" ,libxft)
("mesa" ,mesa)))
(arguments
- `(#:make-flags `("VER_DATE=2014-08-23"
+ `(#:make-flags `("VER_DATE=2018-09-01"
"CONFDIR=/etc/tuxpaint" ;don't write to store
,(string-append "PREFIX=" %output)
"GNOME_PREFIX=$(PREFIX)")
@@ -3645,7 +3651,7 @@ throwing people around in pseudo-randomly generated buildings.")
(define-public hyperrogue
(package
(name "hyperrogue")
- (version "10.4x")
+ (version "10.5")
;; When updating this package, be sure to update the "hyperrogue-data"
;; origin in native-inputs.
(source (origin
@@ -3656,7 +3662,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-src.tgz"))
(sha256
(base32
- "0khk7xqdw4aiw1wnf1xrhmd7fklnzmpdavd7ix4mkm510dr5wklm"))))
+ "04wk50f51xrb9vszwil4ivkfpy7xc6nw3gnp90hbna2zqi2jnvb8"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -3733,7 +3739,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-win.zip"))
(sha256
(base32
- "1dv3kdv1n5imh3n9900b55rf0wwbjj7243lhsbk7lcjqsqxia39q"))))
+ "0r6xvnr7b56iv27n8z10qmxhsz5h7w6ayhxkz3xinlvch84bk708"))))
("unzip" ,unzip)))
(inputs
`(("font-dejavu" ,font-dejavu)