aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5aaf56fb2..b6a63aba02 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2722,16 +2722,12 @@ Transport Tycoon Deluxe.")
(copy-recursively
(string-append objects "/share/openrct2/objects")
"data/object"))))
- (add-before 'configure 'fixgcc7
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
- (add-after 'fixgcc7 'get-rid-of-errors
+ (add-before 'configure 'get-rid-of-errors
(lambda _
;; Don't treat warnings as errors.
(substitute* "CMakeLists.txt"
- (("-Werror") "")))))))
+ (("-Werror") ""))
+ #t)))))
(inputs `(("curl" ,curl)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
@@ -2747,8 +2743,7 @@ Transport Tycoon Deluxe.")
("speexdsp" ,speexdsp)
("zlib" ,zlib)))
(native-inputs
- `(("gcc" ,gcc-7)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(home-page "https://github.com/OpenRCT2/OpenRCT2")
(synopsis "Free software re-implementation of RollerCoaster Tycoon 2")
(description "OpenRCT2 is a free software re-implementation of
@@ -3772,7 +3767,8 @@ throwing people around in pseudo-randomly generated buildings.")
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
- (string-append (assoc-ref inputs "sdl-union")
+ (string-append (getenv "CPATH") ":"
+ (assoc-ref inputs "sdl-union")
"/include/SDL"))))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -4785,7 +4781,7 @@ fight against their plot and save his fellow rabbits from slavery.")
("zlib" ,zlib)))
(native-inputs
`(("boost" ,boost)
- ("cmake" ,cmake)
+ ("cmake" ,cmake-minimal)
("mesa" ,mesa)
("pkg-config" ,pkg-config)
("python-2" ,python-2)))
@@ -4985,7 +4981,8 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-union")
- "/include/SDL2"))
+ "/include/SDL2:"
+ (getenv "CPATH")))
#t))
(delete 'check)
;; premake doesn't provide install target
@@ -5278,7 +5275,7 @@ making Yamagi Quake II one of the most solid Quake II implementations available.
`(("qtbase" ,qtbase)
("qtsvg" ,qtsvg)))
(native-inputs
- `(("cmake" ,cmake)
+ `(("cmake" ,cmake-minimal)
("gettext-minimal" ,gettext-minimal)
("qttools" ,qttools)))
(synopsis "Realistic physics puzzle game")