aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 89634cf914..78443d6f5c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1633,7 +1633,25 @@ formats.")
"138gvgdwk6h4ljrjsr09pxk1nrki4b155hqdzyr8mlk3bwsfmw31"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config))
+ (append (if (and (%current-target-system)
+ (target-riscv64?))
+ (list config)
+ '())
+ (list pkg-config)))
+ (arguments
+ (if (and (%current-target-system)
+ (target-riscv64?))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "build-aux"))
+ '("config.guess" "config.sub"))))))
+ '()))
(inputs
(list eudev))
(home-page "https://0pointer.de/blog/projects/being-smart.html")
@@ -2869,7 +2887,7 @@ compatible with the well-known scripts of the same name.")
(define-public libportal
(package
(name "libportal")
- (version "0.6")
+ (version "0.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2878,7 +2896,7 @@ compatible with the well-known scripts of the same name.")
(file-name (git-file-name name version))
(sha256
(base32
- "1q1kqq72cs7f5b17gzw7218mxs65hijzkll27mh51s02fpiw8c60"))))
+ "0ypl9ds5g5jzyirjg4ic0r7lzv39w67yrh8njz1cw566g4j1kfny"))))
(build-system meson-build-system)
(arguments
(list
@@ -3077,7 +3095,7 @@ for xdg-desktop-portal that is using Qt/KF5.")
(define-public xdg-desktop-portal-wlr
(package
(name "xdg-desktop-portal-wlr")
- (version "0.7.0")
+ (version "0.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3086,7 +3104,7 @@ for xdg-desktop-portal that is using Qt/KF5.")
(file-name (git-file-name name version))
(sha256
(base32
- "1b3hpp3ybjgnnmnwsyb5bsnvz9q5nr3zz0j1alh02g24f68lf00k"))
+ "1mbq3czka9swwmfaasnaj89y2m254p3qa522ayclh688jdwh70hq"))
(patches (search-patches "xdg-desktop-portal-wlr-harcoded-length.patch"))))
(build-system meson-build-system)
(arguments