aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 4c15d4b2b0..20a104f623 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -274,14 +274,14 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.11.0")
+ (version "1.13.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1c0d5ivy9n44hykvw2ggrvqrnn7naw3wg11vbvgwzgi8g5gr4h4m"))))
+ "0lgywr1m0d79vr4s8aimj8a307nss29hhy68gjpqj7m667055c39"))))
(build-system gnu-build-system)
(arguments `(#:parallel-tests? #f))
(native-inputs
@@ -331,7 +331,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public weston
(package
(name "weston")
- (version "1.11.0")
+ (version "2.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -339,7 +339,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"weston-" version ".tar.xz"))
(sha256
(base32
- "09biddxw3ar797kxf9mywjkb2iwky6my39gpp51ni846y7lqdq05"))))
+ "1n35acsknwqfhsni854q5mjq2gnbnfdvinh92rpij67i4yn4dr5l"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -372,9 +372,11 @@ applications, X servers (rootless or fullscreen) or other display servers.")
;; Use elogind instead of systemd
(substitute* "configure"
(("libsystemd-login >= 198") "libelogind"))
- (substitute* '("src/launcher-logind.c" "src/weston-launch.c")
+ (substitute* '("libweston/launcher-logind.c"
+ "libweston/weston-launch.c")
(("#include <systemd/sd-login.h>")
- "#include <elogind/sd-login.h>"))))
+ "#include <elogind/sd-login.h>"))
+ #t))
(add-after 'configure 'patch-confdefs.h
(lambda _
(system "echo \"#define HAVE_SYSTEMD_LOGIN_209 1\" >> confdefs.h")))