aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e69b3cabc4..55afa62176 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,6 +143,7 @@ line client and a client based on Qt.")
(build-system cmake-build-system)
(arguments
`(#:modules ((guix build cmake-build-system)
+ ((guix build gnu-build-system) #:prefix gnu:)
(guix build utils)
(guix build emacs-utils))
#:imported-modules (,@%cmake-build-system-modules
@@ -155,6 +157,10 @@ line client and a client based on Qt.")
,(string-append "-DUTFCPP_INCLUDE_DIR:PATH="
(assoc-ref %build-inputs "utfcpp")
"/include"))
+ ;; Skip failing test BaselineTest_cmd-org during the check phase.
+ ;; This is a known upstream issue. See
+ ;; https://github.com/ledger/ledger/issues/550
+ #:make-flags (list "ARGS=-E BaselineTest_cmd-org")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'install-examples
@@ -165,7 +171,7 @@ line client and a client based on Qt.")
(install-file "test/input/demo.ledger" examples))
#t))
(add-after 'build 'build-doc
- (lambda _ (zero? (system* "make" "doc"))))
+ (lambda _ (invoke "make" "doc")))
(add-before 'check 'check-setup
;; One test fails if it can't set the timezone.
(lambda* (#:key inputs #:allow-other-keys)
@@ -173,6 +179,7 @@ line client and a client based on Qt.")
(string-append (assoc-ref inputs "tzdata")
"/share/zoneinfo"))
#t))
+ (replace 'check (assoc-ref gnu:%standard-phases 'check))
(add-after 'install 'relocate-elisp
(lambda* (#:key outputs #:allow-other-keys)
(let* ((site-dir (string-append (assoc-ref outputs "out")
@@ -182,8 +189,7 @@ line client and a client based on Qt.")
(dest-dir (string-append guix-dir "/ledger-mode")))
(mkdir-p guix-dir)
(rename-file orig-dir dest-dir)
- (emacs-generate-autoloads ,name dest-dir))
- #t)))))
+ (emacs-generate-autoloads ,name dest-dir)))))))
(inputs
`(("boost" ,boost)
("gmp" ,gmp)
@@ -196,7 +202,7 @@ line client and a client based on Qt.")
`(("emacs" ,emacs-minimal)
("groff" ,groff)
("texinfo" ,texinfo)))
- (home-page "http://ledger-cli.org/")
+ (home-page "https://ledger-cli.org/")
(synopsis "Command-line double-entry accounting program")
(description
"Ledger is a powerful, double-entry accounting system that is