aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/esolangs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/esolangs.scm')
-rw-r--r--gnu/packages/esolangs.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 676b355e65..45feedfa28 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Nikita <nikita@n0.is>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
@@ -22,6 +24,8 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages readline)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
@@ -56,6 +60,39 @@ written in C. It supports several @dfn{fingerprints} (opt-in language extension
identified by unique ID codes).")
(license license:gpl3)))
+(define-public lolcode-lci
+ (package
+ (name "lolcode-lci")
+ (version "0.11.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/justinmeza/lci")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("readline" ,readline)))
+ (native-inputs
+ `(("python-2" ,python-2))) ; for the tests
+ (synopsis "LOLCODE interpreter written in C")
+ (description
+ "@code{lci} is a LOLCODE interpreter written in C and is designed to be
+correct, portable, fast, and precisely documented.
+@enumerate
+@item correct: Every effort has been made to test lci's conformance to the
+LOLCODE language specification. Unit tests come packaged with the lci source code.
+@item portable: lci follows the widely ported ANSI C specification allowing it
+to compile on a broad range of systems.
+@item fast: Much effort has gone into producing simple and efficient code
+whenever possible to the extent that the above points are not compromized.
+@end enumerate")
+ (home-page "http://lolcode.org/")
+ (license license:gpl3+)))
+
(define-public shakespeare-spl
(package
(name "shakespeare-spl")