aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm50
1 files changed, 47 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 7eb8bbf893..cf1e988c7a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -67,6 +67,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages digest)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -102,6 +103,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -849,7 +851,6 @@ The viewer can be used interactively with a REPL (for example Geiser in
Emacs).")
(license license:gpl3+))))
-;; TODO Add doc https://gitlab.com/kicad/services/kicad-doc/-/tree/master
(define-public kicad
(package
(name "kicad")
@@ -899,6 +900,9 @@ Emacs).")
#t)))))
(native-search-paths
(list (search-path-specification
+ (variable "KICAD") ; to find kicad-doc
+ (files '("")))
+ (search-path-specification
(variable "KICAD_TEMPLATE_DIR")
(files '("share/kicad/template")))
(search-path-specification
@@ -970,6 +974,46 @@ translations for KiCad.")
(define-public kicad-i18l
(deprecated-package "kicad-i18l" kicad-i18n))
+(define-public kicad-doc
+ (package
+ (name "kicad-doc")
+ (version "5.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/kicad/services/kicad-doc.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03kvss8a0xrjnfvkwymm0vfd7rn9ix7i926xdzz9jg9iycrjfj3g"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_FORMATS=html")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (add-before 'install 'set-perl-env
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "PERL5LIB"
+ (string-append (assoc-ref inputs "perl-unicode-linebreak")
+ "/lib/perl5/site_perl" ":"
+ (getenv "PERL5LIB")))
+ #t))
+ (delete 'check))))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("gettext" ,gettext-minimal)
+ ("git" ,git-minimal)
+ ("perl" ,perl)
+ ("perl-unicode-linebreak" ,perl-unicode-linebreak)
+ ("po4a" ,po4a)
+ ("source-highlight" ,source-highlight)))
+ (home-page "https://kicad.org")
+ (synopsis "KiCad official documentation")
+ (description "This repository contains the official KiCad documentation.")
+ (license license:gpl3+)))
+
(define-public kicad-symbols
(package
(name "kicad-symbols")
@@ -1077,7 +1121,7 @@ the 'showing the effect of'-style of operation.")
(define-public volk
(package
(name "volk")
- (version "2.4.0")
+ (version "2.4.1")
(source
(origin
(method git-fetch)
@@ -1087,7 +1131,7 @@ the 'showing the effect of'-style of operation.")
(recursive? #t))) ; for cpu_features git submodule
(file-name (git-file-name name version))
(sha256
- (base32 "14y0988r5qi1h3yvkivx5ihccn8r15910lq30r8iy71ih190r5m9"))))
+ (base32 "1mkqiw0i2fbbsk46zvk8yv5swl7ifhq6y1dlfphq8dsmkvxckqby"))))
(build-system cmake-build-system)
(arguments
`(#:phases