aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6089a4a114..6653230793 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11118,3 +11118,36 @@ Emacs build on top of mu. Mu is highly efficient making it possible to get
instant results even for huge maildirs. It also provides search operators,
e.g: @code{from:Peter to:Anne flag:attach search term}.")
(license license:gpl3+))))
+
+(define-public emacs-helm-pass
+ (let ((commit "ebcbef1a962795a36e3491ae926e2a4b8a8b0ebb"))
+ (package
+ (name "emacs-helm-pass")
+ (version (git-version "20180416" "1" commit))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/jabranham/helm-pass/archive/"
+ commit
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1pgq4hj9wvz7z2fyxwsvbh6rmc1akya84v382nx26rr76iavz6wi"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-password-store" ,emacs-password-store)))
+ (home-page
+ "https://github.com/jabranham/helm-pass")
+ (synopsis "Helm interface to pass, the standard Unix password manager")
+ (description
+ "Users of @code{helm-pass} may also be interested in functionality
+provided by other Emacs packages dealing with pass:
+@itemize
+@item @code{emacs-password-store}, which @code{helm-pass} relies on.
+@item @code{emacs-pass}, a major mode for @code{pass}.
+@item @code{auth-source-pass.el}: integration of Emacs' auth-source with
+@code{pass}, included in Emacs 26+).
+@end itemize\n")
+ (license license:gpl3+))))