aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 06d82434ce..2f5488c137 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24771,6 +24771,45 @@ sources. It features syntax highlighting, autocompletion, preview of buffer
or region and use of locally installed binaries.")
(license license:gpl3+)))
+(define-public emacs-execline
+ (let ((commit "c75dd9b2c54d8e59fc35fd4bd98d8e213948a3f5")
+ (revision "1"))
+ (package
+ (name "emacs-execline")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/KAction/emacs-execline/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02q531c9wvdwflhggflnci4a36h2bb90bq25bbhw6i2lvrd9sk55"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "-Q" "-batch" "-L" "."
+ "-l" "t/indent.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://gitlab.com/KAction/emacs-execline/")
+ (synopsis "Major Emacs mode for editing execline scripts")
+ (description
+ "This package provides a major mode for editing execline scripts.
+
+Features:
+@itemize
+@item Syntax highlighting of commends, builtin commands and variable substitution.
+@item Completion of builtin commands.
+@item Working @code{comment-region} command.
+@item Indentation of blocks.
+@item Automatic enable of mode in @file{*.exec} files.
+@item Automatic enable of mode in files with @code{execlineb} interpreter.
+@end itemize\n")
+ (license license:gpl3+))))
+
(define-public emacs-shell-pop
(let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")
(revision "0"))