aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index cc43259e26..70ec9ed352 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages qt)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg))
(define-public chmlib
@@ -80,6 +81,7 @@
(delete-file-recursively "src/unrar")
(delete-file "src/odf/thumbnail.py")))
(patches (search-patches "calibre-drop-unrar.patch"
+ "calibre-use-packaged-feedparser.patch"
"calibre-dont-load-remote-icons.patch"
"calibre-no-updates-dialog.patch"))))
(build-system python-build-system)
@@ -116,6 +118,7 @@
("python2-cssutils" ,python2-cssutils)
("python2-dateutil" ,python2-dateutil)
("python2-dbus" ,python2-dbus)
+ ("python2-feedparser" ,python2-feedparser)
("python2-lxml" ,python2-lxml)
("python2-mechanize" ,python2-mechanize)
("python2-netifaces" ,python2-netifaces)