aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 1ab2094dce..804f681e59 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -148,16 +148,10 @@ with arguments to the field constructor.")
(synopsis "Django plugin for py.test")
(description "Pytest-django is a plugin for py.test that provides a set of
useful tools for testing Django applications and projects.")
- (properties `((python2-variant . ,(delay python2-pytest-django))))
(license license:bsd-3)))
(define-public python2-pytest-django
- (let ((base (package-with-python2
- (strip-python2-variant python-pytest-django))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-pytest-django))
(define-public python-django-filter
(package
@@ -180,13 +174,7 @@ useful tools for testing Django applications and projects.")
some of the more mundane bits of view code. Specifically, it allows users to
filter down a queryset based on a model’s fields, displaying the form to let
them do this.")
- (properties `((python2-variant . ,(delay python2-django-filter))))
(license license:bsd-3)))
(define-public python2-django-filter
- (let ((base (package-with-python2
- (strip-python2-variant python-django-filter))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-django-filter))