aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 90035f7255..69c02347c3 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1357,7 +1357,7 @@ reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
(define-public duc
(package
(name "duc")
- (version "1.4.4")
+ (version "1.4.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1366,7 +1366,7 @@ reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
(file-name (git-file-name name version))
(sha256
(base32
- "1i7ry25xzy027g6ysv6qlf09ax04q4vy0kikl8h0aq5jbxsl9q52"))))
+ "0sglcn38rgn6y3m5ahngizyn3x2rzhqjphs7g0ppnlinkz56rcv4"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1383,7 +1383,19 @@ reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/" ,name "-" ,version)))
- (copy-recursively "examples" (string-append doc "/examples"))))))))
+ (copy-recursively "examples" (string-append doc "/examples")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (substitute* "test.sh"
+ ;; Keep the test logs where --keep-failed can see them.
+ (("^(DUC_TEST_DIR=).*" _ assign)
+ (format #f "~a~a/test-directory~%" assign (getcwd)))
+ ;; XXX ‘actual size’ differed on my system (a consistent 348160
+ ;; bytes where the tests expect 540672). However, the ‘apparent
+ ;; size’ matches, as does the actual test output. Good enough…?
+ ((" [0-9]*B actual") " [0-9]*B actual"))
+ (when tests?
+ (invoke "./test.sh"))))))) ; no ‘check’ target
(native-inputs
(list autoconf automake libtool pkg-config))
(inputs