aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8b01a2f01b..be92c416fb 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1349,7 +1349,15 @@ trees (LSM), for sustained throughput under random insert workloads.")
`(("python" ,python-2)))
(inputs `(("postgresql" ,postgresql)))
(arguments
- `(#:tests? #f)) ; # FAIL: 1
+ `(#:tests? #f ; # FAIL: 1
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-sed-command
+ (lambda _
+ ;; Newer sed versions error out if double brackets are not used.
+ (substitute* "configure"
+ (("\\[:space:\\]") "[[:space:]]"))
+ #t)))))
(synopsis "C++ connector for PostgreSQL")
(description
"Libpqxx is a C++ library to enable user programs to communicate with the