aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm32
1 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index f89a423804..ceee88d82b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -20,6 +20,8 @@
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -453,7 +455,7 @@ RDBMS systems (which are deep in functionality).")
(define-public mysql
(package
(name "mysql")
- (version "5.7.19")
+ (version "5.7.20")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -465,7 +467,7 @@ RDBMS systems (which are deep in functionality).")
name "-" version ".tar.gz")))
(sha256
(base32
- "1c8y54yk756179nx4dgg79dijmjdq5n8l057cnqsg70pjdpyfl9y"))))
+ "11v4g3igigv3zvknv67qml8in6fjrbs2vnr3q6bg6f62nydm95sk"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -898,7 +900,7 @@ for example from a shell script.")
(define-public sqlite
(package
(name "sqlite")
- (version "3.19.3")
+ (version "3.20.1")
(source (origin
(method url-fetch)
(uri (let ((numeric-version
@@ -914,7 +916,7 @@ for example from a shell script.")
numeric-version ".tar.gz")))
(sha256
(base32
- "00b3l2qglpl1inx21fckiwxnfq5xf6441flc79rqg7zdvh1rq4h6"))))
+ "0hh7jnxfwvs2qlvmjwrgkvxb8sk4x8hj04m54fq9h1xw55dmjrpc"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments
@@ -934,6 +936,20 @@ widely deployed SQL database engine in the world. The source code for SQLite
is in the public domain.")
(license license:public-domain)))
+;; This is used by Clementine.
+(define-public sqlite-with-fts3
+ (package (inherit sqlite)
+ (name "sqlite-with-fts3")
+ (arguments
+ (substitute-keyword-arguments (package-arguments sqlite)
+ ((#:configure-flags flags)
+ `(list (string-append "CFLAGS=-O2 -DSQLITE_SECURE_DELETE "
+ "-DSQLITE_ENABLE_UNLOCK_NOTIFY "
+ "-DSQLITE_ENABLE_DBSTAT_VTAB "
+ "-DSQLITE_ENABLE_FTS3 "
+ "-DSQLITE_ENABLE_FTS3_PARENTHESIS "
+ "-DSQLITE_ENABLE_FTS3_TOKENIZER")))))))
+
(define-public tdb
(package
(name "tdb")
@@ -1582,14 +1598,14 @@ on another machine, accessed via TCP/IP.")
(define-public python-peewee
(package
(name "python-peewee")
- (version "2.8.3")
+ (version "2.10.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "peewee" version))
(sha256
(base32
- "1605bk11s7aap2q4qyba93rx7yfh8b11kk0cqi08z8klx2iar8yd"))))
+ "10f2mrd5hw6rjklrzaix2lsxlgc8vx3xak54arcy6yd791zhchi3"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ; Fails to import test data
@@ -1728,13 +1744,13 @@ etc., and an SQL engine for performing simple SQL queries.")
(define-public python-lmdb
(package
(name "python-lmdb")
- (version "0.92")
+ (version "0.93")
(source (origin
(method url-fetch)
(uri (pypi-uri "lmdb" version))
(sha256
(base32
- "01nw6r08jkipx6v92kw49z34wmwikrpvc5j9xawdiyg1n2526wrx"))
+ "0xdpb298fyl68acadbwv5801wcwfpnhc7sm4bnrq1x4bd5dhhsql"))
(modules '((guix build utils)))
(snippet
;; Delete bundled lmdb source files.