aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a37e0b0830..14130f442a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34638,3 +34638,27 @@ division with overflow protection
(description
"Library to convert html to pango.")
(license license:gpl3)))
+
+(define-public rust-macro-attr
+ (package
+ (name "rust-macro-attr")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "macro-attr" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0anc4valrldnn0gwaqlhlr4b5zh25g1lyy1x3fq65y1b1rpirr80"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-rustc-serialize" ,rust-rustc-serialize-0.3))))
+ (home-page "")
+ (synopsis
+ "This crate provides the `macro_attr!` macro that enables the use of custom, macro-based attributes and derivations. Supercedes the `custom_derive` crate.")
+ (description
+ "This crate provides the `macro_attr!` macro that enables the use of custom, macro-based attributes and derivations. Supercedes the `custom_derive` crate.")
+ (license (list license:expat license:asl2.0))))