aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bf76e77b04..47cd1d7217 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13864,3 +13864,27 @@ making it possible to download files over HTTPS across platforms. The
@code{RCurl} package provides this functionality (and much more) but has
external dependencies. This package has is implemented purely in R.")
(license license:gpl2)))
+
+(define-public r-rex
+ (package
+ (name "r-rex")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rex" version))
+ (sha256
+ (base32
+ "0alsadgjgass3wr8y5d247j12qqzg454sc84vpskclrkmz778g5x"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lazyeval" ,r-lazyeval)
+ ("r-magrittr" ,r-magrittr)))
+ (home-page "https://github.com/kevinushey/rex")
+ (synopsis "Friendly regular expressions")
+ (description
+ "This package provides a friendly interface for the construction of
+regular expressions. Regular expressions are a very powerful feature, however
+they are often difficult to interpret. Rex allows you to build complex
+regular expressions from human readable expressions")
+ (license license:expat)))