aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fec9947d0d..3657ae1515 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24405,3 +24405,29 @@ designs. Broman et al. (2018) <doi:10.1534/genetics.118.301595>.")
data (variant call format, e.g. VCF or BCF) or meta-analysis results in R.")
;; Any version of the GPL is acceptable
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-maldiquant
+ (package
+ (name "r-maldiquant")
+ (version "1.19.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "MALDIquant" version))
+ (sha256
+ (base32
+ "0b7kdz3x4sdq413h1q09l1qhcvdnnwv6fqsqwllks1cd3xy34c57"))))
+ (properties `((upstream-name . "MALDIquant")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/MALDIquant")
+ (synopsis "Quantitative analysis of mass spectrometry data")
+ (description
+ "This package provides a complete analysis pipeline for matrix-assisted
+laser desorption/ionization-time-of-flight (MALDI-TOF) and other
+two-dimensional mass spectrometry data. In addition to commonly used plotting
+and processing methods it includes distinctive features, namely baseline
+subtraction methods such as morphological filters (TopHat) or the
+statistics-sensitive non-linear iterative peak-clipping algorithm (SNIP), peak
+alignment using warping functions, handling of replicated measurements as well
+as allowing spectra with different resolutions.")
+ (license license:gpl3+)))