aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a3808e9882..f483178656 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24524,3 +24524,34 @@ discovery of differentially expressed genes and markers.")
estimation of phylogenetic trees and networks using Maximum Likelihood,
Maximum Parsimony, distance methods and Hadamard conjugation.")
(license license:gpl2+)))
+
+(define-public r-diversitree
+ (package
+ (name "r-diversitree")
+ (version "0.9-13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "diversitree" version))
+ (sha256
+ (base32
+ "00vi4klywi35hd170ksjv3xja3hqqbkcidcnrrlpgv4179k0azix"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (inputs `(("fftw" ,fftw) ("gsl" ,gsl)))
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-desolve" ,r-desolve)
+ ("r-rcpp" ,r-rcpp)
+ ("r-subplex" ,r-subplex)))
+ (home-page "https://www.zoology.ubc.ca/prog/diversitree")
+ (synopsis "Comparative 'phylogenetic' analyses of diversification")
+ (description "This package contains a number of comparative \"phylogenetic\"
+methods, mostly focusing on analysing diversification and character evolution.
+Contains implementations of \"BiSSE\" (Binary State Speciation and Extinction)
+and its unresolved tree extensions, \"MuSSE\" (Multiple State Speciation and
+Extinction), \"QuaSSE\", \"GeoSSE\", and \"BiSSE-ness\" Other included methods
+include Markov models of discrete and continuous trait evolution and constant
+rate speciation and extinction.")
+ (license license:gpl2+)))