aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ba966fff6c..22355c3bc5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12023,6 +12023,32 @@ statistics, with applications to @dfn{single-nucleotide polymorphism} (SNP)
data.")
(license license:gpl2+)))
+(define-public r-acsnminer
+ (package
+ (name "r-acsnminer")
+ (version "0.16.8.25")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ACSNMineR" version))
+ (sha256
+ (base32
+ "0gh604s8qall6zfjlwcg2ilxjvz08dplf9k5g47idhv43scm748l"))))
+ (properties `((upstream-name . "ACSNMineR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)))
+ (home-page "https://cran.r-project.org/web/packages/ACSNMineR")
+ (synopsis "Gene enrichment analysis")
+ (description
+ "This package provides tools to compute and represent gene set enrichment
+or depletion from your data based on pre-saved maps from the @dfn{Atlas of
+Cancer Signalling Networks} (ACSN) or user imported maps. The gene set
+enrichment can be run with hypergeometric test or Fisher exact test, and can
+use multiple corrections. Visualization of data can be done either by
+barplots or heatmaps.")
+ (license license:gpl2+)))
+
(define-public r-units
(package
(name "r-units")